La semaine dernière en rentrant du boulot ma femme me dit que l'iMac est planté et qu'il replante tout le temps. Il affiche en effet des trucs bizarres et reste figé quelques minutes après le boot. Un rapide SSH me confirme ce que je pensais : c'est la carte graphique qui semble avoir des vapeurs :

Jun 23 19:58:31 mac kernel[0]: NVDA(OpenGL): Channel exception! exception type = 0xd = GR: SW Notify Error
Jun 23 19:58:31 mac kernel[0]: 0000006e
Jun 23 19:58:31 mac kernel[0]: 00200000 00008297 00000474 00000010
Jun 23 19:58:31 mac kernel[0]: 0000047e 00001408 00000001 00000011
Jun 23 19:58:31 mac kernel[0]: 00000000 00000000 00000403
Jun 23 19:58:31 mac kernel[0]: 00000010 00000000

J'entreprends donc un démontage en règle pour voir si jamais quelque chose n'aurait pas bougé dans la bête. Malheureusement non, tout est bien en place. J'essaie donc de réinstaller l'OS sur un autre disque dur pour voir si ce n'est pas logiciel, malheureusement même le boot de l'installateur de MacOS plante. Après remontage du disque dur original de l'iMac, il se trouve qu'il plante même encore plus tôt dans la séquence de boot, il ne dépasse même plus l'EFI!

2011-07-02_14.22.56.jpg

Bref, je laisse tombé, on verra après les vacances...

...Retour de vacances hier, je démonte tout et là je vois que la pâte thermique est un peu fatiguée, resultat ce matin je vais chez les chinois et j'achète de la pâte toute neuve, je la remplace, je remonte tout, pas mieux, snif :'(

Je vais donc sur le net en quête d'une nouvelle carte graphique, sachant qu'il en faut une compatible EFI et qui rentre dans l'espace prévu ça ne va pas être facile. En cherchant ca je trouve des gens qui parlent de cartes graphiques diverses et variées ayant les mêmes problèmes, que ce soit des CG PC, Mac, portable, fixes, ... Mais toutes des NVidia. Il semblerait que la soudure utilisée sur les cartes ne soit pas de bonne qualité et craque avec le temps et la chaleur. Certains malades ont l'idée de mettre leurs cartes au four afin de reformer les soudures... Banco! perdu pour perdu on y va!

Je redémonte donc tout, je nettoie la carte de sa patte thermique, je fais chauffer le four à 200°C, j'enfourne mon plat avec ma carte graphique posée sur 4 blocs de papier d'alu, j'attends les 10 minutes de cuisson, 30 minutes de refroidissement, je remonte le tout, et YAAALAAAA! Ca marche! Truc de dingue!

Bref ça fait maintenant 45 minutes que le mac tourne sans problèmes, je vais lancer un petit Starcraft II pour confirmer ça ;)

Pour ceux qui pourraient avoir les mêmes problèmes voici mon modèle d'iMac : Spec sur le site d'Apple.

C'est le modèles 24" avec la NVidia 8800 GS.

Quelques photos :

Le tout démonté :

2011-07-01_19.43.46.jpg

Les petits plots en alu :

2011-07-02_14.37.06.jpg

Aller hop, 10 minutes au four !

2011-07-02_14.38.35.jpg 2011-07-02_14.39.45.jpg 2011-07-02_14.40.12.jpg

Yaaaalaaa :

2011-07-02_16.06.17.jpg

A+ pour de nouvelles recettes d'iMac !